DDK버전 과 Windows 버전 설정

DDK 버전

Windows Longhorn, WDK
WLHBASE, D:\WINDDK\6000
Windows XP, Server 2003 with SP1
WXPBASE, D:\WINDDK\2600, D:\WINDDK\3790.1830
Windows 2000
W2KBASE, D:\Nt50DDK
Windows NT
NT4BASE, D:\NT4DDK
1. DDK help 에서 windows 2003 이상을 지원할때 코딩시 정의는?
MSDN을 보면
Constant Operating system version
NTDDI_WIN2K Windows 2000
NTDDI_WIN2KSP1 Windows 2000 with Service Pack 1 (SP1)
NTDDI_WIN2KSP2 Windows 2000 with Service Pack 2 (SP2)
NTDDI_WIN2KSP3 Windows 2000 with Service Pack 3 (SP3)
NTDDI_WIN2KSP4 Windows 2000 with Service Pack 4 (SP4)
NTDDI_WINXP Windows XP
NTDDI_WINXPSP1 Windows XP with SP1
NTDDI_WINXPSP2 Windows XP with SP2
NTDDI_WS03 Windows Server 2003
NTDDI_WS03SP1 Windows Server 2003 with SP1
NTDDI_LONGHORN Windows Vista

코딩은 아래와 같이
#if (NTDDI_VERSION >= NTDDI_WINXP)
...Window XP 이상에서 필요한 코드...
#endif


2.
OSRonline에서 사용하는 DDKBUILD util 을 사용할때 xxxBASE 및 build 설정은?

NET ddk를 사용하여 XP이상을 지원하는 드라이버를 작성하고 싶다면 WXPBASE=D:\WINDDK\3790.1830 와 같이 설정하고 build -WNETXP free -cez 라고 설정하면 된다.
Longhorn DDK(WDK)를 사용하여 Server 2003 이상을 지원하는 드라이버를 작성하고 싶다면 WLHBASE=D:\WINDDK\6000  로 설정하고 build -WLHNET free -ceZ라고 설정하면 된다.

x64 드라이버는 build -WLHNETX64 free -ceZ와 같이 하면 된다.
신고
Trackback 1 Comment 0
prev 1 ··· 8 9 10 11 12 13 14 15 16 ··· 652 next


티스토리 툴바